Принимаю условия соглашения и даю своё согласие на обработку персональных данных и cookies.

Yahoo Messenger «открыт» для атак: критическая уязвимость

9 июня 2007, 10:17
В интернет-пейджере Yahoo Messenger обнаружена критическая уязвимость. Модуль ActiveX, обеспечивающий видеосвязь через веб-камеры, содержит ошибку типа «переполнение буфера», позволяющую выполнить произвольный код при удалённой атаке.

Суть ошибки – в неправильной обработке длинных имён серверов в функции send() и receive() – отправки и получения - библиотек ywcupl.dll и ywcvwr.dll. Эксплоиты уже циркулируют по Сети в открытом доступе, сообщает Heise-security.co.uk.

Уязвим Yahoo Messenger версии 8.1.0.249 и, возможно, программы более ранних версий. Для защиты от уязвимости необходимо отключить уязвимые компоненты - установить вручную флаг совместимости («killbit») для классов с CLSID {DCE2F8B1-A520-11D4-8FD0-00D0B7730277} и {9D39223E-AE8E-11D4-8FD3-00D0B7730277} в реестре.